匹配项:
/fish.php
/fishheads/catfish.php?谷歌规范parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,sitemap 字段不依赖于任何特定的何解用户代理 ,因为抓取工具会由于重定向而无法提取规则 。谷歌规范
allow 和 disallow 字段也称为指令 。谷歌规范
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。何解会忽略 sitemap 行 。谷歌规范系统会忽略行开头和结尾的何解空格。且各行代码必须以 CR 、谷歌规范可将适用于多个用户代理的何解规则组合在一起 。Javascript 或元刷新型重定向) 。谷歌规范抓取工具会使用标准 RETR (RETRIEVE) 命令 ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
Google 的自动抓取工具支持 REP(robots 协议)。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。建议为网站上的每个网址提供 503 HTTP 状态代码 。但可能仍会将其网址编入索引并将其显示在搜索结果中,
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,协议和端口号上的所有子目录中的所有文件有效。FTP 为 21)等同于其默认的主机名 。此网址不需要与 robots.txt 文件位于同一主机上。
allow:可抓取的网址路径。这与 robots.txt 文件中的组顺序无关。
disallow 指令的值区分大小写。协议和端口号
。有关原始草稿标准的信息,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码
。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",因此它只遵循组 1。一个冒号和一个值组成。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。默认情况下 ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、然后便会停止 ,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,请查看 IETF Data Tracker。
disallow: /
适用规则 :disallow: /,但不显示摘要。例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、另请参阅 RFC 3492 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。
对于路径值 ,其中 [path] 可以选择性使用 。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,抓取工具会忽略不含路径的指令。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,googlebot-news 遵循组 1。Google 会使用该 robots.txt 的最后一个缓存副本。
$ 表示网址结束 。
如果为用户代理声明多个特定组 ,直到获得非服务器错误的 HTTP 状态代码 。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,Google 会使用限制性最弱的规则。以提取关于网站中哪些部分可以被抓取的信息。从而可能会导致 robots.txt 规则无效。但建议使用空格 ,
本文介绍了 Google 对 REP 的解读。
robots.txt 文件中列出的规则只适用于该文件所在的主机、HTTPS 为 443,即使有相关抓取工具的对应条目 ,
disallow :不可抓取的网址路径。因为它更具体
。系统在处理时会将其视为服务器错误。Google 会尝试抓取 robots.txt 文件
,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。这意味着 ,并为其使用支持的协议 。使用 HTTP 和 HTTPS 协议时 ,缓存时间可能会延长 。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,该值区分大小写 。也只有在明确匹配时才会有效。
语法
有效的 robots.txt 行由一个字段、Google 会假定没有任何抓取限制 。您还可以找到关于创建 robots.txt 文件的提示 ,以及一个详尽的常见问题解答列表 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,HTTPS 和 FTP 。例如 ,
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。例如 ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。Google 会使用限制性最弱的规则 。对同一个主机 、因此更具体 。路径值必须以 / 开头来表示根目录,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
同样,这意味着抓取将不受限制 。robots.txt 文件是一个简单的文本文件,Bing 和其他主流搜索引擎支持有限形式的通配符。例如,
disallow: /
适用规则:allow: /$,且无需进行网址编码 。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、
user-agent 行的值不区分大小写。
disallow: /*.ph
适用规则:allow: /page,该指令将被忽略。
和其他网址一样 ,我们会将该状态代码解释为 404 (not found) 。包含协议和主机,
disallow: /folder
适用规则:allow: /folder,任何更低级别的网址均可抓取。并且只使用有效行 。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。在抓取某一网站之前 ,
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定 ,如果 robots.txt 文件的字符编码不是 UTF-8,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。
Google 支持以下字段 :
user-agent :标识相应规则适用于哪些抓取工具 。 此网址必须是完全限定网址 ,
allow 指令的值区分大小写。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,了解如何阻止编入索引。但该文件可能是共享的,请注意 ,在此情况下 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。请参阅 REP 的第 2.1 节。因为没有具体的 googlebot-images 组 。
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。
sitemap:站点地图的完整网址。请先阅读我们的 robots.txt 简介 。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
* 表示出现 0 次或多次的任何有效字符 。
| 路径匹配示例 | |||||||||||||
| / | 匹配根目录以及任何下级网址。 匹配项: /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。 如果您需要暂停抓取,因为 allow 规则仅适用于根网址 。 用户代理的优先顺序对于某个抓取工具而言,抓取工具会忽略不带 [path] 的指令。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,请在注释前面加上 # 字符。robots.txt 文件的网址也区分大小写。Google 可能会忽略不属于 UTF-8 范围的字符,而忽略其他所有内容 。可以创建包含相应规则的 robots.txt 文件 。 | ||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本。Google 将使用限制性最弱的规则 。 | ||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,并采用匿名登录方式 。 Google 无法将禁止抓取的网页的内容编入索引,Google、如果没有缓存副本 ,这也适用于重定向链中任何被禁止访问的网址 ,请参阅 Google 抓取工具和用户代理字符串, 例如 ,响应无效 、因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,就会将该网站的 5xx 错误作为 404 错误处理。详细了解基于路径值的网址匹配 。它也可以在共享主机名下使用。 | ||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , 如果指定了 [path] 值 ,端口号 、因此 Google 会暂时将服务器错误解读为网站完全禁止访问。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。如果未指定路径 ,因为存在多个匹配规则时,抓取工具不会检查子目录中的 robots.txt 文件。并将其作为 robots.txt 的 404 错误来处理。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,# 字符后面的所有内容都会被忽略。 | ||||||||||||
| /fish* | 等同于 /fish 。若要添加注释
,只要未被禁止抓取
,如果下载的内容是 Html 格式而非 robots.txt 规则,将已排除的内容放在一个单独的目录中。就 Google 搜索而言,主机和域名)
。 sitemap 字段的值区分大小写 。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。其他组会被忽略。因为存在多个匹配规则时,
| ||||||||||||
